• Welcome to the Muppet Central Forum!
    You are viewing our forum as a guest. Join our free community to post topics and start private conversations. Please contact us if you need help.
  • Christmas Music
    Our 19th annual Christmas Music Marathon is underway on Muppet Central Radio. Listen to the best Muppet Christmas music of all-time through December 25.
  • 50 Years and Counting
    Read our review and discuss with fans the highly anticipated Sesame Street "50 Years and Counting" DVD set from Shout Factory featuring over five hours of beloved moments.
  • 50th Anniversary Celebration
    Read fan reactions and let us know your thoughts on Sesame Street's 50th anniversary special. An official DVD is on the way.
  • "Muppets Now" announced for Disney+
    It's finally official. A new, unscripted short-form series, “Muppets Now”, is coming to Disney+ in 2020. Let us know your thoughts on the Muppets big announcement.
  • The Dark Crystal: "Age of Resistance"
    After a 36 year wait, return to the great conjunction. The Dark Crystal "Age of Resistance" is a mesmerizing and beautiful prequel series now on Netflix. Renew your essence today.
  • Music is Everywhere
    Muppet Central Radio is now on TorontoCast, TuneIn and Apple Music. Listen to Muppet music 24/7 wherever you go with TuneIn and Apple apps and devices.

Links not working on home page

MuppetsRule

Well-Known Member
Joined
Dec 2, 2002
Messages
1,943
Reaction score
1,064
Noticed this yesterday. On the Muppet Central Homepage when I click on the links in the top banner they do not work. If I click on the Forums tab it does nothing. When I click on the Collectibles tab it does nothing. None of the tabs work on the homepage. They seem to work from any other page.

Anybody else have this problem

I am using the Firefox browser
 

Phillip

Administrator
Staff member
Joined
Apr 11, 2002
Messages
7,413
Reaction score
2,972
Noticed this yesterday. On the Muppet Central Homepage when I click on the links in the top banner they do not work. If I click on the Forums tab it does nothing. When I click on the Collectibles tab it does nothing. None of the tabs work on the homepage. They seem to work from any other page.
Thank you. This has been fixed. Please let us know if you see anything else not working properly.
 
Top